$re = '/((?<!\S)[^.?!;]*?<mark>.+?(?>[.?;!](?!\S)|\z))(?>(?>\h+.+?[.;?!])*?\h+(?1))*/im';
$str = 'harum quidem rerum facilis est et expedita distinctio? Nam libero tempore, cum soluta nobis est eligendi optio <mark>cumque</mark> nihil impedit .23 quo minus id 0.89 quod maxime placeat facere possimus, omnis voluptas assumenda est, 12.34 omnis dolor repellendus! Itaque earum rerum hic tenetur a sapiente delectus, quod maxime placeat
At vero eos et accusamus et iusto odio dignissimos ducimus. Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do <mark>eiusmod</mark> tempor incididunt ut labore et dolore <mark>magna</mark> aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea <mark>commodo</mark> consequat? Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur! Excepteur sint <mark>occaecat</mark> cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum; sed ut perspiciatis unde omnis iste natus error sit voluptatem accusantium doloremque laudantium, totam rem aperiam?
velit esse cillum dolore eu fugiat nulla pariatur! Excepteur sint <mark>occaecat</mark> cupidatat non proident, sunt in';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);