#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((xxx|yyy)(,(?!$)|$))+$"
Local $sString = "xxx" & @CRLF & _
"yyy" & @CRLF & _
"xxx,xxx" & @CRLF & _
"yyy,xxx" & @CRLF & _
"xxx,yyy,yyy,yyy" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"xx" & @CRLF & _
"yyyy" & @CRLF & _
"xxx," & @CRLF & _
"xxxyyy" & @CRLF & _
"xxx,,yyy" & @CRLF & _
",xxx,yyy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")