$re = '/^\[([^\]]+)]:.*\s(.+)\s\(ID:\s(\d+)\).*\s(\d{0,3}(?::\d{0,3}){3}).*\s([a-zA-z\d]+)$/';
$str = '[20-Nov-2015 14:49:55 +0200]: Successful login for user name (ID: 299) from 127:0:0:1 in session 70573git16bu1otp0jpugm8q14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);