$re = '/\b<@*>\b/';
$str = '<@287993113794969600> add';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);