#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(!~)|[!~]"
Local $sString = "!Tim !~ Dan~"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)