#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)IllegalArgumentException\n\s*at\s+(.+)(?:\n\s*at(?!\s*com\.test).*)*\n\s*at\s+((com\.test[^(\n]*).*)(?:\n\s*at.*)*\n\s*at\s+(?!\3)(com\.test.*)"
Local $sString = "IllegalArgumentException" & @CRLF & _
"" & @CRLF & _
" at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)" & @CRLF & _
" at java.security.AccessController.doPrivileged(Native Method)" & @CRLF & _
" at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)" & @CRLF & _
" at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)" & @CRLF & _
" at com.test.package1.user1.client1.client1.Call.invoke(Call.java:90)" & @CRLF & _
" at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)" & @CRLF & _
" at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)" & @CRLF & _
" at com.test.package1.user1.client1.client1.Call.invoke(SrvCall.java:84)" & @CRLF & _
" at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)" & @CRLF & _
" at java.security.AccessController.doPrivileged(Native Method)" & @CRLF & _
" at com.test.package2.user2.client2.client2.Call.invoke(Call.java:90)" & @CRLF & _
" at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)" & @CRLF & _
" at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)" & @CRLF & _
" at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)" & @CRLF & _
" at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")