# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<Registry>[a-z0-9\-.]+\.[a-z0-9\-]+:?[0-9]*)?/?((?P<Name>[a-zA-Z0-9-_]+?)|(?P<UserName>[a-zA-Z0-9-_]+?)/(?P<ImageName>[a-zA-Z-_]+?))(:(?P<Tag>[a-zA-Z0-9-_\\.]+?)|)$"
test_str = ("localhost.local:6000/worker-ocr:20423.32.41-R212-7843\n"
"test.azurecr.io/worker-ocr:20423.32.41-R212-7843\n"
"docker.io/bitnami/minideb:buster\n"
"docker.io/bitnami/redis-exporter:1.21.0-debian-10-r1\n"
"docker.io/bitnami/redis:6.2.2\n"
"docker.io/bitnami/postgresql:12.2.0\n"
"docker.io/bitnami/postgres-exporter:0.7.0-debian-9-r12\n"
"docker.io/bitnami/minideb:stretch\n"
"docker.io/bitnami/fluentd:1.12.0-debian-10-r0\n"
"fluent/fluent-bit:1.3.7\n"
"consul:1.8.2\n"
"curlimages/curl:latest\n"
"hashicorp/consul:1.9.7\n"
"k8s.gcr.io/defaultbackend-amd64:1.5\n"
"k8s.gcr.io/ingress-nginx/controller:v1.0.4\n"
"ghcr.io/kedacore/keda:2.2.0\n"
"ghcr.io/kedacore/keda-metrics-apiserver:2.2.0\n"
"docker.io/busybox")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.