re = /^([0-9]\.[0-9]{1}|[0-9]\.[0-9]{2}|\.[0-9]{2}|[1-9][0-9]\.[0-9]{1}|[1-9][0-9]\.[0-9]{2}|[0-9][0-9]|[1-9][0-9]\.[0-9]{2})$|^([0-9]|[0-9][0-9]|[0-99])$|^100$/m
str = '99.99
100000
1000
1001
991
558
63.7
66.
44.33
01.3
90.5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end