import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?:(?:UP)?LOAD|FOO|DOG|WEDNESDAY)\\]([\\s\\S]*)";
final String string = "Lorem ipsum[LOAD]lorem ipsum Lorem ipsum \"Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation[another text] ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat[dummy] non proident,[FOO] sunt in culpa qui officia deserunt mollit anim id est laborum.\"\n\n\n"
+ "Lorem ipsum[LOAD]lorem ipsum Lorem ipsum \"Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation[another text] ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat[dummy] non proident,[FOO] sunt in culpa qui officia deserunt mollit anim id est laborum.\"\n\n\n";
final String subst = "[REPLACEMENT]$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}