$re = '/(0-9)(?<=foo)bar$/m';
$str = '3foobar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);