$re = '/\b\d\.\d{2}\b/';
$str = '2.22, 3.12, 0.34, 12.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);