$re = '/(?<=\D)(?=\d)|(?<=\d)(?=\D)/';
$str = '12345hello
hello12345bye';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);