package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([-+] ?)?[0-9]+(,[0-9]+)?$`)
var str = `123,456,789
-12,34
1234
-8
1,2,345
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}