$re = '/^\/wiki(?:\/[^\/]+\?edit=1|\/)?$/m';
$str = '/wiki
/wiki/
/wiki/123?edit=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);