$re = '/^([\d]{1,2}):?([\d]{1,2})?\:([\d]{1,2})/m';
$str = '01:20:55 (h:m:s)
20:30 (m:s)
1:21 (m:s)
1:35:12 (h:m:s)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);