re = /\b(dance|ballet|design|film|(?<!liberal |culinary |language )arts?|music|photograph(ic|y)|theat(er|re)|performing|visual)\b/
str = 'arts
liberal arts
culinary arts
language arts
martial arts'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end