re = /(\bc\"\>)(.+)\<\/a/
str = '<h3 class="r"><a class="pstl" data-what="1" href="http://www.google.de/aclk?sa=l&ai=C-9oQygENVpujKqGXzAOfn... jsaction="spop.c">10 x Leitz Stehsammler 24230095 DIN A476mm Hartpappe RC schwarz</a></h3>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end