using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bc\"">(.+)<\/a";
string input = @"<h3 class=""r""><a class=""pstl"" data-what=""1"" href=""http://www.google.de/aclk?sa=l&ai=C-9oQygENVpujKqGXzAOfn... jsaction=""spop.c"">10 x Leitz Stehsammler 24230095 DIN A476mm Hartpappe RC schwarz</a></h3>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}