#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^(?!ss|ww|.[iou]|[iou].)([a-z]{2})[-\s]?(\d{3})[-\s]?(?!ss|ww|.[iou]|[iou].)([a-z]{2})$"
Local $sString = "AA-123-BB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")