use strict;
my $str = 'pattern 1
no match
file:foobar.jpg
file:foobar,jpg
file:foobar.jpg,ogg
file:foobar,jpg,ogg
match
file:foobar,jpg.ogg
file:foobar.jpg.ogg
pattern 2
no match
file:foobar.jpg
file:foobar,jpg
file:foobar. jpg
file:foobar, jpg
file:foobar.,jpg
file:foobar ,jpg
match
file:foobar .jpg
file:foobar,.jpg
both pattern 1 and 2 match
file:foobar.webm,.tif
file:foobar.ogv .pdf
file:foobar,wav .flac
file:Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.jpg';
my $regex = qr/^(?:File:(?(DEFINE)(?'ext'(png|gif|jpe?g|tiff?|xcf|pdf|mid|og[gva]|svg|djvu|flac|opus|wav|web[mp]))).*([ ,]\.(?&ext)|[,.](?&ext)\.(?&ext)))$/uimp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}