$re = '/^[0-9]*((0[0-9])|(1[01]))$/m';
$str = '508
08
8
13
513
512
511';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);