re = /^(?:[sr]|p[^tae]).*/m
str = 'pit
spot
spate
slap two
respite
pt
Pot
peat
part'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end