# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Title: (?<Title>.*$)[\s\S]*(?<PhoneNumber>\d{10})[\s\S]*When: (?<Date>.[a-zA-Z]*\s.\d*\s.[a-zA-Z]*\s\d*)\s(?<Time>.[0-9]*:[0-9]*[am|pm]* \S [0-9]*:[0-9]*[am|pm]*)[\s\S]*Where: (?<Where>.*?.*$)"
test_str = ("You have been invited to the following event.\n\n"
"Title: לקוח רועי\n"
"0544710385\n"
"When: Sat 28 Nov 2020 9:30pm – 10:30pm Israel Time\n"
"Where: Mazal Keshet Street, Mazal Keshet St, Hod Hasharon, Israel\n\n"
"Joining info: Join with Google Meet\n"
"https://meet.google.com/ngv-fxvo-oyt\n\n"
"Calendar: mplmp5e1vpvapd7fl5euj7g81ytfzlem@hook.integromat.com\n"
"Who:\n"
" * ecmanager8@gmail.com- organiser\n"
" * My Automation\n\n"
"Event details: \n"
"https://calendar.google.com/calendar/event?action=VIEW&eid=NnNvbTJjMW82Z3I2YWJiMmNvbzM2YjlrYzloNmFiOW82Y3FtYWJiMWM0cDNnb3I1NzBzMzJkOXA2YyBtcGxtcDVlMXZwdmFwZDdmbDVldWo3ZzgxeXRmemxlbUBob29rLmludGVncm9tYXQuY29t&tok=MjAjZWNtYW5hZ2VyOEBnbWFpbC5jb20yODdjNWU1ZjU2ZjVjNWIwZmE4NmYwOTMxNzY5NTczMGNhNGJiN2E3&ctz=Asia%2FJerusalem&hl=en_GB&es=0\n\n"
"Invitation from Google Calendar: https://calendar.google.com/calendar/\n\n"
"You are receiving this courtesy email at the account \n"
"mplmp5e1vpvapd7fl5euj7g81ytfzlem@hook.integromat.com because you are an \n"
"attendee of this event.\n\n"
"To stop receiving future updates for this event, decline this event. \n"
"Alternatively, you can sign up for a Google Account at \n"
"https://calendar.google.com/calendar/ and control your notification \n"
"settings for your entire calendar.\n\n"
"Forwarding this invitation could allow any recipient to send a response to \n"
"the organiser and be added to the guest list, invite others regardless of \n"
"their own invitation status or to modify your RSVP. Learn more at \n"
"https://support.google.com/calendar/answer/37135#forwarding")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.