$re = '/(?<!\S)\S+(?=-input(?!\S))/m';
$str = 'new-profile-input';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);