package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/([^./]*)[^/]*$`)
var str = `https://www.website.com/cat1/cat2/naming/id.and.something.else.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}