$re = '/(?<![$\d])\d+\.\d{2}(?!\d)/m';
$str = '$100.00 50.00
1.99 $150.50 200.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);