# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|\ |\n)(((?:(?:http(?:s)?\:)?(?:\/\/))|(?:\/\/))?(?:(?=[a-z0-9\-\.]{1,255}(?=\/|\ |$|\:|\n|\?|\,|\!))(?:(?:(?:[a-z0-9]{1}(?:[a-z0-9\-]{1,62})?\.){1,127})[a-z]{2,}(?:\.[a-z]{2})?))(?:[a-z0-9\/\-\_\%\?\&\!\$\'\,\(\)\*\.\+\=\;])*?)(?=$|\.(?=\ |$)|\:|\n|\ |\?(?=\ |$)|\,|\!)"
test_str = ("I really like to go to google.com and google stuff.\n"
" <br>\n"
" I also like http://hercdev.io, both are pretty cool!\n"
"http://google.com\n"
" <br>\n"
" This is the url to an image: https://objects.dreamhost.com/herc-scripts/chicken_sombrero.gif\n"
" <br>\n"
" But this is the actual image: <img src=\"https://objects.dreamhost.com/herc-scripts/chicken_sombrero.gif\" style=\"max-width: 100px;\" />\n"
" <br>\n"
" Note that the url to the image in the <img> tag is unaffected. This is true for things that are already links also, like <a href=\"http://google.com\" target=\"_blank\">this.</a>")
subst = "<a href=\"$1\">$1</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.