import Foundation
let pattern = #"(?=(\boh\b(?:(?!\boh\b).)*?\bwell\b|\bwell\b(?:(?!\bwell\b).)*?\boh\b))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
oh i mean well i do n't know well he 's like oh
yeah so well he did n't say oh he said f** well you know what he 's like
oh you know well why well maybe he thought oh well good
oh my god well what the hell did he oh you know
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)