$re = '/(?s)var\s+kaynaklar.*?url\s*:\s*"([^"]+)"\s*,\s*data\s*:\s*\'([^\']+)/';
$str = 'var kaynaklar = [];
jQuery.ajax({
type:"POST",
url:"/service/part",
data:\'id=31398\',
success:function(a){
if(a=="hata")
{
jQuery("#player").html("<br><br><font style=\'color:white;\'>Video kaynağı silinmiş lütfen sol üstten Kaynak butonuna tıklayarak farklı bir kaynak deneyin.</font>")
}
else
{
for (var i = 1; i < 6; i++) {
if(a["videolink"+i])
{
kaynaklar.push({"file":a["videolink"+i], "label":a["videokalite"+i],"type":"mp4"});
}
}
video_loader();
}
},
error:function(){
jQuery("#player").html("<br><br><font style=\'color:white;\'>Video yüklenirken bir hata oluştu lütfen sayfayı yenileyip tekrar deneyin veya farklı bir kaynak deneyin.</font>")
}
})';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);