use strict;
my $str = '"""BEAVER COUNTY 001 0000
1010 BEAVER
2010 BEAVER COUNTY SCH DIST
0.008504
0.008508
4010 COUNTY SPECIAL SERVICE DIST NO.1 <---capture this 4010
4040 BEAVER COUNTY
8005 GREENVILLE SOLAR
0.004258
0.008348
...(more decimals)
0.008238
4060 SPECIAL SERVICE DISTRICT NO 7 <---capture this 4060
"""';
my $regex = qr/((\d+\.\d+)\s+)+(\d+)\s?(?=\w+)/mp;
my $subst = '\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";