package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d*\.?\d*$`)
var str = `123456.891`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}