#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bDELIVER TO:\R\h*(\S+).*(?:\R.*){2}.*\h(\S+)"
Local $sString = "RECOVER FROM:" & @CRLF & _
"LUFTHANSA CARGO - FRA" & @CRLF & _
"FLIGHT: LH441" & @CRLF & _
"ETA: SUN 25-APR-2021 09:09" & @CRLF & _
"WAYBILL: 020-90350573" & @CRLF & _
"ORIGIN: IAH" & @CRLF & _
"SERVICE: ZXO Courier Solution" & @CRLF & _
"x0Wx0H in. 109 lbs (49.0 kg) Skid" & @CRLF & _
"" & @CRLF & _
"DELIVER TO:" & @CRLF & _
"VITESCO TECHNOLOGIES CZECH REPUBLIC S.R.O" & @CRLF & _
"VOLANOVSKA 518" & @CRLF & _
"TRUTNOV 541 01 CZ" & @CRLF & _
"ATTN: ADAM STUCHLIK" & @CRLF & _
"PHONE: +420 731 593 139" & @CRLF & _
"EST. DISTANCE: 293 miles" & @CRLF & _
"" & @CRLF & _
"PCS/WT: 1 / 49.0 kg (109 lbs)" & @CRLF & _
"DIMS: 1@82x82x51cm" & @CRLF & _
"ORDER#: 10659800" & @CRLF & _
"CONTENTS: PCV PANNEL" & @CRLF & _
"SERVICE: Next Flight Out(NFO)" & @CRLF & _
"" & @CRLF & _
"URGENT! PLEASE CONFIRM THIS ALERT BY EMAILING CnwGermanyOps@cnwglobal.com OR CALLING COURIER NETWORK INC. AT 800-852-2282"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")