re = /([^\s,]+.(?!\s)\w*[^,]\b)/i
str = 'hello world, foo, bar, test1, test2, another-test, hooray'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end