$re = '/a(b(c(d(e(f()?+)?+)?+)?+)?+)?+/';
$str = 'abcxef';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);