re = /\/(en-US|en-GB|en-AU|fr-CA|en-CA|es-MX|tr-TR)*\/+(lgl-platform)/m
str = '/lgl-platform'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end