// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.*\r?\n){5}").unwrap();
let string = "
Name: Full Report
Store: River North (Wells St)
Date Tripped: 19 Feb 2020 1:07 PM
Business Date: 19 Feb 2020 (Open)
Message:
Information:
This alert was tripped based on a user defined trigger: Every 15 minutes.
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Etiam mauris eros, varius in facilisis et, ultrices ac dolor. Curabitur sapien purus, elementum at semper ac, euismod sed dui. Vivamus ac dui pellentesque nunc blandit feugiat. Sed in consectetur lacus. Aliquam sollicitudin odio tortor, nec ultricies magna pharetra id. Vivamus a fringilla risus. Phasellus ac dui at erat porttitor laoreet. Mauris a nulla dignissim, iaculis turpis vitae, accumsan enim.
Pellentesque pretium eleifend sapien, eu accumsan risus efficitur quis. Sed nec tincidunt lacus. Donec a leo sem. Suspendisse posuere lacus at sem ullamcorper convallis. In elit mi, placerat non quam sit amet, aliquet porta turpis. Fusce cursus rutrum sodales. Aenean dui risus, pharetra vel massa ut, interdum sollicitudin turpis. Quisque fringilla risus urna, a viverra est viverra vel. Aenean ut mauris ut tellus dictum volutpat vel vitae lectus. Nullam dignissim sit amet magna fringilla eleifend. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Integer lacus mauris, sagittis venenatis fringilla sit amet, lacinia quis massa.
Suspendisse rhoncus sem at sem vehicula rutrum. Etiam interdum sed purus eget pharetra. Cras interdum fringilla viverra. Proin viverra lobortis quam, ut accumsan neque aliquam in. Vestibulum faucibus vulputate ex malesuada cursus. Proin semper ex posuere metus pharetra, at accumsan nunc placerat. Nunc viverra porta magna ut pulvinar. Vivamus imperdiet quam imperdiet elit imperdiet tempus. Pellentesque tempus dolor vitae vulputate mollis.
Donec hendrerit nulla sed leo blandit molestie. Donec id dui laoreet, iaculis risus id, ornare quam. Proin eget mi in urna porttitor auctor eu eu nulla. Aliquam facilisis, nibh congue tempus varius, lacus sapien efficitur massa, in malesuada augue elit eget enim. Nunc et mollis metus. Aenean ultrices vitae nunc at porttitor. Donec sodales felis orci, id aliquet elit imperdiet eget. Pellentesque vulputate vel arcu in iaculis. Aliquam nec lacus tortor. Donec cursus nibh eget leo consectetur rutrum. Sed aliquam ornare nisi, ac cursus justo sodales sit amet. Fusce dignissim consectetur gravida. Integer sit amet tincidunt quam. Donec sollicitudin, nisi blandit convallis aliquam, lectus leo mollis magna, non molestie magna massa vitae enim. Phasellus tempor sollicitudin ligula id hendrerit. Suspendisse sagittis velit in consequat dignissim.
Phasellus tincidunt, turpis quis euismod commodo, quam lorem elementum metus, vitae fringilla orci lectus eget mauris. Nunc pellentesque tempor ex in blandit. Morbi sed purus sed eros interdum consequat. Suspendisse vitae neque id quam ullamcorper placerat. Proin nisl magna, egestas sit amet dictum id, vulputate sed dui. Morbi ultrices mauris id purus posuere accumsan. In eget ornare nibh. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Suspendisse eget consequat orci. Nam at enim mollis lacus pellentesque feugiat vel non tellus. Aliquam condimentum metus cursus tristique rhoncus. Integer maximus purus vel dui ullamcorper, a scelerisque nulla lobortis. Donec sed tortor sollicitudin, malesuada purus in, ultrices neque. Sed egestas, elit facilisis ornare pellentesque, nisl felis mattis tellus, ut euismod felis dui ut felis. Nullam vitae orci sit amet nunc interdum vehicula nec non dolor. Curabitur commodo enim non turpis faucibus dictum. ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}