package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`invalid\semail\saddress:\s(?<invalid_email>[^\[]*)\[Email\]`)
var str = `Error: Update failed. First exception on row 0 with id abcd; first error: INVALID_EMAIL_ADDRESS, Email: invalid email address: jrwils@secuamp;gt;: [Email]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}