$re = '%(?<=^|\s)(?:#(\w+))(?=\s|$)%u';
$str = '#dddddd
#dddd
dd#ddd
#dddd--dd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);