re = /^neodecksoftware\.com$/m
str = 'www.neodecksoftware.com
neodecksoftware.com
sillyneodecksoftware.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end