const regex = /^https:\/\/www.themoviedb.org\/list\/([a-zA-Z0-9\_-]++)(?!\/edit)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/www.themoviedb.org\\\/list\\\/([a-zA-Z0-9\\_-]++)(?!\\\/edit)(.*)', 'gm')
const str = `https://www.themoviedb.org/list/8301863-my-favorite-movies/edit?active_nav_item=step_2
https://www.themoviedb.org/list/8301863-my-favorite-movies
https://www.themoviedb.org/list/8301863-my-favorite-movies/edit`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}