import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[wptabsy((?!\\[\\/wptabsy\\])(.|\\s))*\\[\\/wptabsy\\]";
final String string = "[wptabsy color=\"asdfasdfasdf\"]\n"
+ "[tab]Tab One[/tab]\n"
+ "[tab icon=\"fa-tags\"]Tab Two[/tab]\n"
+ "[tab icon=\"fa-arrow-right\"]Tab Three[/tab]\n"
+ "[tab]Tab Four[/tab]\n"
+ "[tabcontent]Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.\n\n"
+ "Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit, sed quia non numquam eius modi tempora incidunt ut labore et dolore magnam aliquam quaerat voluptatem. [/tabcontent]\n"
+ "[tabcontent]Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.\n\n"
+ "[reviewr]\n\n"
+ "Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.[/tabcontent]\n"
+ "[tabcontent]Sed ut perspiciatis unde omnis iste natus error sit voluptatem accusantium doloremque laudantium, totam rem aperiam, eaque ipsa quae ab illo inventore veritatis et quasi architecto beatae vitae dicta sunt explicabo. Nemo enim ipsam voluptatem quia voluptas sit aspernatur aut odit aut fugit, sed quia conse[/tabcontent]<br /><br />\n"
+ "[/wptabsy]\n\n"
+ "asdfasdf\n\n"
+ "[wptabsy alignment=\"left\" active=\"dd3333,,\" inactive=\",,\" tabcontent=\",,\"][tabcontent][/tabcontent][/wptabsy]\n\n"
+ "[wptabsy alignment=\"left\" active=\",,\" inactive=\",,\" tabcontent=\",,\"][tab icon=\"fa-music\"]asdfasdf[/tab][tabcontent][/tabcontent][/wptabsy]\n\n"
+ " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}