import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(Type: )(?<type>\\w+)) *(?:(Year: )(?<year>\\d{4})) *(?:(Title: )(?<title>[^ISBN]*))(?:(ISBN:) *(?<ISBN>\\d*))* *(?:(Pages: )(?<pages>\\d*))* *(?:(Authors: )(?<author1>(?:(?:(?!Length: )[\\w ,])*) *)) *;* *(?<author2>(?:(?:(?!Length: )[\\w ,])*) *)(?:(Length: )(?<length>\\d*))* *(?:Media Type: )*(?<discType>[\\w ,]*)";
final String string = "Type: eBook Year: 1990 Title: This is ebook 1 ISBN:15465452 Pages: 100 Authors: Cendric, Paul\n"
+ "Type: Movie Year: 2016 Title: This is movie 1 Authors: Pepe Giron ; Yamasaki Suzuki Length: 4500 Media Type: DVD\n"
+ "Type: Movie Year: 2016 Title: This is movie 1 Authors: Pepe Giron Length: 4500 Media Type: DVD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}