package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?P<my_group>fo[-\w]+)`)
var str = `foo-bar
bar-foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}