re = /$(?<!\.(?:png|css)$)/m
str = 'http://gioplet/articles
http://gioplet/img/logo.png
http://gioplet/index.php
http://gioplet/css/main.css'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end