re = /(\d+)\s(\d+)\s([^\.]*)/m
str = 'STRING 1 160 Some descriptor information. /Uselessstuff.; STRING 161 274 Some other descriptor information. /Moreuselessstuff.; STRING 275 1070 Last descriptor info. /Lastuselesspart'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end