re = /func\s*.*\s*{\n.*?((?!\{.*\}).)*}/
str = 'override func someting() {
halloworld() {
anotherfunc() {};
};
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end