#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<a.+>??>"
Local $sString = "asldjkgjasdkjgasdk" & @CRLF & _
"<a>test</a>lol" & @CRLF & _
"<a>am</a>" & @CRLF & _
"asdhjfgasdjkgdaskj" & @CRLF & _
"<a>bfasjdg as</a>" & @CRLF & _
"abab"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")