$re = '/^[a-zA-Z]{4,}(?: [a-zA-Z]+){0,2}$/m';
$str = 'dj
p o lice
john c mather';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);