import re
regex = re.compile(r"((?:\b(?!\.))(?!.*\.\..*)(?:[a-zA-Z0-9\.\-\+_\-]+?)?[a-zA-Z0-9]+?|\"\s\"|\"[a-zA-Z0-9]+?\.\.[a-zA-z0-9]+?\")@([a-zA-Z0-9]+(?:\-[a-zA-Z0-9])?\.?[a-zA-Z0-9]+(?:\.[a-zA-Z]+)?)", flags=re.MULTILINE)
test_str = ("ss.s.s+eee-eee_eeee@gmail.com é o meu email. \n"
"O e-mail a@a1-m.com.br também pertence @ mim.com.br!!!@cc.com \n\n"
"example@s.example\n"
"simple@example.com\n"
"very.common@example.com\n"
"disposable.style.email.with+symbol@example.com\n"
"other.email-with-hyphen@example.com\n"
"fully-qualified-domain@example.com\n"
"user.name+tag+sorting@example.com\n"
"example-indeed@strange-example.com\n"
"admin@mailserver1\n"
"\" \"@example.org\n"
"\"john..doe\"@example.org\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")