package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`regex`)
var str = `324F8D8A20561205231920`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}